brcm47xx: add missing config symbol
[openwrt/openwrt.git] / target / linux / brcm47xx / modules.mk
index 5738d6aa0d4099763b94543219fd6dc0dba8fb0f..9146b3f464968f2ac7f5011f6eaf46ec0eb41823 100644 (file)
@@ -5,44 +5,10 @@
 # See /LICENSE for more information.
 #
 
-define KernelPackage/usb-brcm47xx
-  SUBMENU:=$(USB_MENU)
-  TITLE:=Support for USB on bcm47xx
-  DEPENDS:=@USB_SUPPORT @TARGET_brcm47xx
-  KCONFIG:= \
-       CONFIG_USB_HCD_BCMA \
-       CONFIG_USB_HCD_SSB
-  FILES:= \
-       $(if $(CONFIG_USB_HCD_BCMA),$(LINUX_DIR)/drivers/usb/host/bcma-hcd.ko) \
-       $(if $(CONFIG_USB_HCD_SSB),$(LINUX_DIR)/drivers/usb/host/ssb-hcd.ko)
-  AUTOLOAD:=$(call AutoLoad,19, \
-       $(if $(CONFIG_USB_HCD_BCMA),bcma-hcd) \
-       $(if $(CONFIG_USB_HCD_SSB),ssb-hcd),1)
-  $(call AddDepends/usb)
-endef
-
-$(eval $(call KernelPackage,usb-brcm47xx))
-
-
-define KernelPackage/ocf-ubsec-ssb
-  TITLE:=BCM5365P IPSec Core driver
-  DEPENDS:=@TARGET_brcm47xx +kmod-crypto-ocf
-  KCONFIG:=CONFIG_OCF_UBSEC_SSB
-  FILES:=$(LINUX_DIR)/crypto/ocf/ubsec_ssb/ubsec_ssb.ko
-  AUTOLOAD:=$(call AutoLoad,10,ubsec_ssb)
-  $(call AddDepends/crypto)
-endef
-
-define KernelPackage/ocf-ubsec-ssb/description
-  This package contains the OCF driver for the BCM5365p IPSec Core
-endef
-
-$(eval $(call KernelPackage,ocf-ubsec-ssb))
-
 define KernelPackage/bgmac
   TITLE:=Broadcom bgmac driver
-  KCONFIG:=CONFIG_BGMAC
-  DEPENDS:=@TARGET_brcm47xx
+  KCONFIG:=CONFIG_BGMAC CONFIG_BGMAC_BCMA
+  DEPENDS:=@TARGET_brcm47xx @!TARGET_brcm47xx_legacy
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/bgmac.ko
   AUTOLOAD:=$(call AutoLoad,19,bgmac,1)