brcm2708: fix image generation with imagebuilder
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index af45cf47c6fb78021fa12648da551bddf2b5d6d1..d0222df0652b7d155a5de5ccc095eaeec5691a09 100644 (file)
@@ -12,6 +12,10 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+define Build/Compile
+       $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
+endef
+
 ### Image scripts ###
 define Build/kernel-img
        perl $(LINUX_DIR)/scripts/mkknlimg $@ $@.tmp
@@ -21,7 +25,7 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
-       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
+       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
@@ -30,7 +34,7 @@ define Build/boot-img
        mcopy -i $@.boot $(KDIR)/fixup_cd.dat ::
        mcopy -i $@.boot cmdline.txt ::
        mcopy -i $@.boot config.txt ::
-       mcopy -i $@.boot $(word 1,$^) ::kernel.img
+       mcopy -i $@.boot $(IMAGE_KERNEL) ::kernel.img
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
        mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
@@ -38,7 +42,7 @@ define Build/boot-img
 endef
 
 define Build/sdcard-img
-       ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
+       ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
        $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
@@ -49,12 +53,10 @@ define Device/Default
   KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
   IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_DTS
 
 define Device/rpi
-  DEVICE_TITLE := Raspberry Pi B/B+/CM
+  DEVICE_TITLE := Raspberry Pi B/B+/CM/Zero
   DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
 endef
 ifeq ($(SUBTARGET),bcm2708)
@@ -65,16 +67,16 @@ define Device/rpi-2
   DEVICE_TITLE := Raspberry Pi 2 B
   DEVICE_DTS := bcm2709-rpi-2-b
 endef
-ifeq ($(SUBTARGET),bcm2708)
+ifeq ($(SUBTARGET),bcm2709)
   TARGET_DEVICES += rpi-2
 endif
 
 define Device/rpi-3
-  DEVICE_TITLE := Raspberry Pi 3 B
-  DEVICE_DTS := bcm2710-rpi-3-b
-  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+  DEVICE_TITLE := Raspberry Pi 3 B/CM
+  DEVICE_DTS := bcm2710-rpi-3-b bcm2710-rpi-cm3
+  DEVICE_PACKAGES := brcmfmac-firmware-43430-sdio kmod-brcmfmac wpad-mini
 endef
-ifeq ($(SUBTARGET),bcm2708)
+ifeq ($(SUBTARGET),bcm2710)
   TARGET_DEVICES += rpi-3
 endif