brcm2708: fix SUBTARGET checks for bcm2709/bcm2710
[openwrt/openwrt.git] / target / linux / brcm2708 / image / Makefile
index f96dccb09f578035c18dbf32c2593eeb93e74389..269e0159c95190bd89318093d34a9b31a96eff7c 100644 (file)
@@ -1,5 +1,6 @@
 # 
 # Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -20,8 +21,8 @@ endef
 define Build/boot-img
        rm -f $@.boot
        mkfs.fat -C $@.boot $(FAT32_BLOCKS)
+       mcopy -i $@.boot $(LINUX_DIR)/COPYING ::COPYING.linux
        mcopy -i $@.boot $(KDIR)/bootcode.bin ::
-       mcopy -i $@.boot $(KDIR)/COPYING.linux ::
        mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
        mcopy -i $@.boot $(KDIR)/start.elf ::
        mcopy -i $@.boot $(KDIR)/start_cd.elf ::
@@ -32,7 +33,7 @@ define Build/boot-img
        mcopy -i $@.boot $(word 1,$^) ::kernel.img
        $(foreach dts,$(shell echo $(DEVICE_DTS)),mcopy -i $@.boot $(DTS_DIR)/$(dts).dtb ::;)
        mmd -i $@.boot ::/overlays
-       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
+       mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtbo ::/overlays/
        mcopy -i $@.boot $(DTS_DIR)/overlays/README ::/overlays/
 endef
 
@@ -42,39 +43,39 @@ define Build/sdcard-img
        $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
 endef
 
-### Device macros ###
+### Devices ###
 define Device/Default
   FILESYSTEMS := ext4
-  PROFILES = Default $$(DEVICE_PROFILE)
   KERNEL := kernel-bin | kernel-img
   IMAGES := sdcard.img
   IMAGE/sdcard.img := boot-img | sdcard-img
-  DEVICE_PROFILE :=
   DEVICE_DTS :=
 endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS
 
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define bcm270x
-  define Device/$(2)
-    DEVICE_PROFILE := $(1)
-    DEVICE_DTS := $(3)
-  endef
-  TARGET_DEVICES += $(2)
+define Device/rpi
+  DEVICE_TITLE := Raspberry Pi B/B+/CM
+  DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
 endef
-
-### BCM2708/BCM2835 ###
 ifeq ($(SUBTARGET),bcm2708)
-  # Raspberry Pi Models B/B+/CM
-  $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+  TARGET_DEVICES += rpi
 endif
 
-### BCM2709/BCM2836 ###
+define Device/rpi-2
+  DEVICE_TITLE := Raspberry Pi 2 B
+  DEVICE_DTS := bcm2709-rpi-2-b
+endef
 ifeq ($(SUBTARGET),bcm2709)
-  # Raspberry Pi 2 Model B
-  $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+  TARGET_DEVICES += rpi-2
+endif
+
+define Device/rpi-3
+  DEVICE_TITLE := Raspberry Pi 3 B
+  DEVICE_DTS := bcm2710-rpi-3-b
+  DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+endef
+ifeq ($(SUBTARGET),bcm2710)
+  TARGET_DEVICES += rpi-3
 endif
 
 $(eval $(call BuildImage))