brcm2708: add Raspberry Pi 2 support
[openwrt/openwrt.git] / target / linux / brcm2708 / Makefile
index c6d72bcbdd4259a093e5a974e053b4ba11cc3283..3ba9ac8069087f8caab2d34912d0d3194c27e797 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2012-2013 OpenWrt.org
+# Copyright (C) 2012-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,19 @@ include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
-BOARDNAME:=Broadcom BCM2708/BCM2835
+BOARDNAME:=Broadcom BCM2708/BCM2709
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-KERNEL_PATCHVER:=3.14
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
 
 define Target/Description
-       Build firmware image for Broadcom BCM2708/BCM2835 SoC devices.
+       Build firmware image for Broadcom BCM2708/BCM2709 SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef