bcm53xx: add basic support for Netgear R7900
[openwrt/openwrt.git] / target / linux / bcm53xx / patches-4.4 / 306-ARM-BCM5301X-Add-DT-for-Netgear-R8500.patch
index 1576065754966f0c5f3ca37095531475c654f831..98a670c463af3e309eb21f84ae350eabec05daad 100644 (file)
@@ -13,8 +13,8 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -78,6 +78,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm4709-netgear-r7000.dtb \
+@@ -79,6 +79,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
+       bcm4709-netgear-r7900.dtb \
        bcm4709-netgear-r8000.dtb \
        bcm47094-dlink-dir-885l.dtb \
 +      bcm47094-netgear-r8500.dtb \
@@ -23,7 +23,7 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
        bcm953012k.dtb
 --- /dev/null
 +++ b/arch/arm/boot/dts/bcm47094-netgear-r8500.dts
-@@ -0,0 +1,31 @@
+@@ -0,0 +1,107 @@
 +/*
 + * Broadcom BCM470X / BCM5301X ARM platform code.
 + * DTS for Netgear R8500
@@ -49,6 +49,82 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 +      memory {
 +              reg = <0x00000000 0x08000000>;
 +      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              power0 {
++                      label = "bcm53xx:white:power";
++                      gpios = <&chipcommon 2 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              power1 {
++                      label = "bcm53xx:amber:power";
++                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              5ghz-1 {
++                      label = "bcm53xx:white:5ghz-1";
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              5ghz-2 {
++                      label = "bcm53xx:white:5ghz-2";
++                      gpios = <&chipcommon 12 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              2ghz {
++                      label = "bcm53xx:white:2ghz";
++                      gpios = <&chipcommon 13 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              usb2 {
++                      label = "bcm53xx:white:usb2";
++                      gpios = <&chipcommon 17 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              usb3 {
++                      label = "bcm53xx:white:usb3";
++                      gpios = <&chipcommon 18 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys";
++              #address-cells = <1>;
++              #size-cells = <0>;
++
++              brightness {
++                      label = "Backlight";
++                      linux,code = <KEY_BRIGHTNESS_ZERO>;
++                      gpios = <&chipcommon 1 GPIO_ACTIVE_LOW>;
++              };
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 10 GPIO_ACTIVE_LOW>;
++              };
++
++              wps {
++                      label = "WPS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++              };
++
++              rfkill {
++                      label = "WiFi";
++                      linux,code = <KEY_RFKILL>;
++                      gpios = <&chipcommon 20 GPIO_ACTIVE_LOW>;
++              };
++      };
 +};
 +
 +&uart0 {