bcm53xx: prepare to support Asus RT-N18U
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 4f225988619376dd6e47be6eb3fd606f25af56ec..968388380a10528b5f54b80a0c5f3a3611fcd959 100644 (file)
@@ -37,6 +37,15 @@ define Image/Build/DTB
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/$(1)-$(2).dts $(KDIR)/$(1)-$(2).lzma -d16
 endef
 
+# $(1): filesystem type (e.g. squashfs, initramfs).
+# $(2): dts filename (also used for the firmware file).
+# $(3): device specific magic.
+define Image/Build/AsusTrx
+       $(call Image/Build/$(1)/DTB,$(2))
+       # TODO: Put magic in TRX file
+       cp $(KDIR)/$(IMG_PREFIX)-$(2)-$(1).trx $(BIN_DIR)/
+endef
+
 # $(1): filesystem type (e.g. squashfs, initramfs).
 # $(2): dts filename (also used for the firmware file).
 define Image/Build/Trx
@@ -55,6 +64,8 @@ endef
 
 # $(1): filesystem type (e.g. squashfs, initramfs).
 define Image/Build
+       $(call Image/Build/AsusTrx,$(1),bcm47081-asus-rt-n18u,RT-N18U)
+
        $(call Image/Build/Trx,$(1),bcm4708-buffalo-wzr-1750dhp)
 
        $(call Image/Build/Chk,$(1),bcm4708-netgear-r6250,U12H245T00_NETGEAR,1)