bcm53xx: add profiles for devices with FullMAC chipsets
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 0709643b29bc04780291e60b03e586893d1cebc3..4e3f12c82b1ab72f6a592b2c5b1c285e156e57e0 100644 (file)
@@ -26,7 +26,7 @@ define Build/trx-serial
        $(STAGING_DIR_HOST)/bin/trx \
                -o $@.new \
                -m 33554432 \
-               -f $(word 1,$^) -a 1024 \
+               -f $(IMAGE_KERNEL) -a 1024 \
                -f $@ -a 0x10000 -A $(KDIR)/fs_mark
        mv $@.new $@
 endef
@@ -39,7 +39,7 @@ define Build/trx-nand
        $(STAGING_DIR_HOST)/bin/trx \
                -o $@.new \
                -m 33554432 \
-               -f $(word 1,$^) -a 0x20000 -b 0x400000 \
+               -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
                -f $@ \
                -A $(KDIR)/ubi_mark -a 0x20000
        mv $@.new $@
@@ -57,7 +57,7 @@ define Build/seama-nand
                entity $@.entity \
                -m "dev=/dev/mtdblock/7" \
                -m "type=firmware" \
-               -f $(word 1,$^) \
+               -f $(IMAGE_KERNEL) \
                -b 0x400000 \
                -f $@ \
                -f $(KDIR)/ubi_mark
@@ -68,7 +68,7 @@ define Build/seama-nand
                -i $@.entity
 endef
 
-DEVICE_VARS += DEVICE_DTS PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
 
 define Device/Default
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
@@ -116,6 +116,14 @@ define DLinkDevice
   TARGET_DEVICES += dlink-$(1)
 endef
 
+define Device/dlink-dir-885l
+  DEVICE_TITLE := D-Link DIR-885L
+  DEVICE_PACKAGES := kmod-brcmfmac
+  $(Device/dlink)
+  SIGNATURE := wrgac42_dlink.2015_dir885l
+endef
+TARGET_DEVICES += dlink-dir-885l
+
 define Device/netgear
   IMAGES := chk
   IMAGE/chk := append-ubi | trx-nand | netgear-chk
@@ -141,11 +149,15 @@ define Device/netgear-r6300-v2
 endef
 
 define Device/netgear-r8000
+  DEVICE_TITLE := Netgear R8000
+  DEVICE_PACKAGES := kmod-brcmfmac
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H315T00_NETGEAR
 endef
 
 define Device/smartrg-sr400ac
+  DEVICE_TITLE := SmartRG SR400ac
+  DEVICE_PACKAGES := kmod-brcmfmac
   IMAGES := trx
   IMAGE/trx := append-rootfs | trx-serial
 endef
@@ -160,7 +172,6 @@ $(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
 $(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
 $(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
 $(eval $(call AsusDevice,rt-n18u,RT-N18U))
-$(eval $(call DLinkDevice,dir-885l,wrgac42_dlink.2015_dir885l))
 $(eval $(call LinksysDevice,ea6300-v1))
 $(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
 $(eval $(call NetgearDevice,r7900,U12H315T30_NETGEAR))