bcm27xx: add kernel 5.10 support
[openwrt/openwrt.git] / target / linux / bcm27xx / modules / sound.mk
index dab31d81324fa027c7b75e779bca2b7ff01c8316..5073e5ff50fffed9e06dbe4aa1ccd533e21bcdf1 100644 (file)
@@ -365,6 +365,26 @@ endef
 $(eval $(call KernelPackage,sound-soc-audioinjector-pi-soundcard))
 
 
+define KernelPackage/sound-soc-chipdip-dac
+  TITLE:=Support for ChipDip DAC
+  KCONFIG:= \
+    CONFIG_SND_BCM2708_SOC_CHIPDIP_DAC
+  FILES:= \
+    $(LINUX_DIR)/sound/soc/bcm/snd-soc-chipdip-dac.ko
+  AUTOLOAD:=$(call AutoLoad,68,snd-soc-chipdip-dac)
+  DEPENDS:= \
+    kmod-sound-soc-bcm2835-i2s \
+    @LINUX_5_10
+  $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-chipdip-dac/description
+  This package contains support for ChipDip DAC
+endef
+
+$(eval $(call KernelPackage,sound-soc-chipdip-dac))
+
+
 define KernelPackage/sound-soc-digidac1-soundcard
   TITLE:=Support for RRA DigiDAC1
   KCONFIG:= \