atheros: remove odd board check during image build
[openwrt/openwrt.git] / target / linux / atheros / Makefile
index 91dadea7efbe9d5dd9ea15ab8e7512aaf0fccdba..170d4afd3b975b69ce16668bb2309edc6eaf5752 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=2.6.37.4
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-madwifi gpioctl swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards