atheros: remove odd board check during image build
[openwrt/openwrt.git] / target / linux / atheros / Makefile
index 6a88fc5a05806d4f3ec8936461be7687010ffc9a..170d4afd3b975b69ce16668bb2309edc6eaf5752 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=atheros
-BOARDNAME:=Atheros 231x/5312
-FEATURES:=squashfs jffs2 pci usb
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=2.6.25.1
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards