atheros: remove odd board check during image build
[openwrt/openwrt.git] / target / linux / atheros / Makefile
index 453f896b517b5bfd3abe1ea095a0865876e77a3d..170d4afd3b975b69ce16668bb2309edc6eaf5752 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=atheros
-BOARDNAME:=Atheros
-FEATURES:=squashfs jffs2
+BOARDNAME:=Atheros AR231x/AR5312
+FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=2.6.23
+KERNEL_PATCHVER:=3.18
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards