ar71xx: add support for UniFi-AC-Mesh
[openwrt/openwrt.git] / target / linux / ar71xx / image / ubnt.mk
index 7a1fc80deaf0e9b2f1906c47238851a7dfe4e64f..84eaaaa9652d8d1799a466752a358988d8fd3553 100644 (file)
@@ -133,6 +133,11 @@ define Device/ubnt-unifiac-lite
   BOARDNAME := UBNT-UF-AC-LITE
 endef
 
+define Device/ubnt-unifiac-mesh
+  $(Device/ubnt-unifiac-lite)
+  DEVICE_TITLE := Ubiquiti UniFi AC-Mesh
+endef
+
 define Device/ubnt-unifiac-pro
   $(Device/ubnt-unifiac)
   DEVICE_TITLE := Ubiquiti UniFi AC-Pro
@@ -147,7 +152,7 @@ define Device/ubnt-unifi-outdoor
   BOARDNAME := UBNT-U20
   DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
 endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifiac-pro ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifiac-mesh ubnt-unifiac-pro ubnt-unifi-outdoor
 
 define Device/ubnt-nano-m-xw
   $(Device/ubnt-xw)
@@ -219,7 +224,7 @@ define Device/ubnt-routerstation
 endef
 
 define Device/ubnt-rs
-$(Device/ubnt-routerstation)
+  $(Device/ubnt-routerstation)
   DEVICE_TITLE := Ubiquiti RouterStation
   BOARDNAME := UBNT-RS
   DEVICE_PROFILE := UBNT UBNTRS
@@ -229,7 +234,7 @@ $(Device/ubnt-routerstation)
 endef
 
 define Device/ubnt-rspro
-$(Device/ubnt-routerstation)
+  $(Device/ubnt-routerstation)
   DEVICE_TITLE := Ubiquiti RouterStation Pro
   BOARDNAME := UBNT-RSPRO
   DEVICE_PROFILE := UBNT UBNTRSPRO
@@ -239,7 +244,7 @@ $(Device/ubnt-routerstation)
 endef
 
 define Device/ubnt-ls-sr71
-$(Device/ubnt-routerstation)
+  $(Device/ubnt-routerstation)
   DEVICE_TITLE := Ubiquiti LS-SR71
   BOARDNAME := UBNT-LS-SR71
   DEVICE_PROFILE := UBNT
@@ -266,7 +271,7 @@ define Device/ubnt-uap-pro
 endef
 
 define Device/ubnt-unifi-outdoor-plus
-$(Device/ubnt-uap-pro)
+  $(Device/ubnt-uap-pro)
   DEVICE_TITLE := Ubiquiti UniFi Outdoor Plus
   UBNT_CHIP := ar7240
   BOARDNAME := UBNT-UOP