ar71xx: provide support for RB-941-2nD via mach-rbspi.c
[openwrt/openwrt.git] / target / linux / ar71xx / image / mikrotik.mk
index a2b682f5f6411684e43aedc3d726fc10b13c11b0..c7cf15d061d14fc2944c3fc3383c96489558d7ba 100644 (file)
@@ -1,5 +1,6 @@
 define Device/mikrotik
   PROFILES := Default
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
   BOARD_NAME := routerboard
   KERNEL_INITRAMFS :=
   KERNEL_NAME := loader-generic.elf
@@ -24,7 +25,8 @@ endef
 TARGET_DEVICES += nand-64m nand-large
 
 define Device/rb-nor-flash-16M
-  DEVICE_TITLE := MikroTik RouterBoard with 16 MB NOR flash
+  DEVICE_TITLE := MikroTik RouterBoard with 16 MB SPI NOR flash
+  DEVICE_PACKAGES := rbcfg
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16000k
   LOADER_TYPE := elf
@@ -35,11 +37,4 @@ define Device/rb-nor-flash-16M
   IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
 endef
 
-define Device/rb-941-2nd
-$(Device/rb-nor-flash-16M)
-  DEVICE_TITLE := hAP lite
-  DEVICE_PACKAGES:= rbcfg
-  BOARDNAME:= rb-941-2nd
-endef
-
-TARGET_DEVICES += rb-nor-flash-16M rb-941-2nd
+TARGET_DEVICES += rb-nor-flash-16M