ar71xx: enable nand-utils in the mikrotik subtarget to ensure it makes it to initramfs
[openwrt/openwrt.git] / target / linux / ar71xx / image / mikrotik.mk
index 6aa7c2a1aeb2e636743f2a20131096eae9219b17..bcfa64da62d4a0483a2c524168d5175f6570f986 100644 (file)
@@ -1,6 +1,6 @@
 define Device/mikrotik
   PROFILES := Default
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport nand-utils
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
   BOARD_NAME := routerboard
   KERNEL_INITRAMFS :=
   KERNEL_NAME := loader-generic.elf
@@ -26,7 +26,7 @@ TARGET_DEVICES += nand-64m nand-large
 
 define Device/rb-nor-flash-16M
   DEVICE_TITLE := MikroTik RouterBoard with 16 MB NOR flash
-  DEVICE_PACKAGES := rbcfg
+  DEVICE_PACKAGES := rbcfg -nand-utils
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16000k
   LOADER_TYPE := elf