ar71xx: improve Mikrotik hAP Lite device support
[openwrt/openwrt.git] / target / linux / ar71xx / image / mikrotik.mk
index ff14f90ca6aeb539aaf7de69bc7bcb6de69bf09c..7a3a9ceed82fdccc08463ec40a979ad7ecfa1212 100644 (file)
@@ -22,7 +22,6 @@ endef
 TARGET_DEVICES += nand-64m nand-large
 
 define Device/rb-nor-flash-16M
-  DEVICE_PROFILE := Default
   BLOCKSIZE := 64k
   IMAGE_SIZE := 16000k
   LOADER_TYPE := elf
@@ -35,7 +34,9 @@ endef
 
 define Device/rb-941-2nd
 $(Device/rb-nor-flash-16M)
+  DEVICE_TITLE := hAP lite
+  DEVICE_PACKAGES:= rbcfg
   BOARDNAME:= rb-941-2nd
 endef
 
-TARGET_DEVICES += rb-941-2nd
+TARGET_DEVICES += rb-nor-flash-16M rb-941-2nd