ar71xx: add support for GL.iNet GL-USB150
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 01c5bdc6772604da35f02143c06db87113b732a1..f0b2179f4485598084012e466c3042325d7fe41e 100644 (file)
@@ -278,6 +278,19 @@ define Device/gl-mifi
 endef
 TARGET_DEVICES += gl-mifi
 
+define Device/gl-usb150
+  DEVICE_TITLE := GL.iNet GL-USB150
+  DEVICE_PACKAGES := -swconfig
+  BOARDNAME := GL-USB150
+  IMAGE_SIZE := 16000k
+  CONSOLE := ttyATH0,115200
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+  SUPPORTED_DEVICES := gl-usb150
+  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += gl-usb150
+
 define Device/lima
   DEVICE_TITLE := 8devices Lima
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2