ar71xx: add support for gl-mifi
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index cb57dba986460bd0a4d6112a9c3b7fe950a64c8e..6e5ef2b68b75b19fb5c48c389823ea8997f7b1d0 100644 (file)
@@ -77,6 +77,16 @@ define Device/gl-domino
 endef
 TARGET_DEVICES += gl-domino
 
+define Device/gl-mifi
+  DEVICE_TITLE := GL MIFI
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+  BOARDNAME = GL-MIFI
+  IMAGE_SIZE = 16000k
+  CONSOLE = ttyATH0,115200
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += gl-mifi
+
 define Device/dr531
   DEVICE_TITLE := Wallys DR531
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2