ar71xx: add support for 8devices Lima board
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 23847612c08a39b4fc58286cbcb8eca28342c210..02f074796e2a0bb9e2fc7d627afb5e0b631f6db3 100644 (file)
@@ -161,6 +161,15 @@ define Device/gl-mifi
 endef
 TARGET_DEVICES += gl-mifi
 
+define Device/lima
+  DEVICE_TITLE := Lima board from 8Devices
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+  BOARDNAME = LIMA
+  IMAGE_SIZE = 15616k
+  MTDPARTS = spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,256k(art)ro,-(firmware)
+endef
+TARGET_DEVICES += lima
+
 define Device/mr12
   DEVICE_TITLE := Meraki MR12
   DEVICE_PACKAGES := kmod-spi-gpio