ar71xx: add support for the Senao EAP7660D board
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index e27912e48dceabdb638fed1f601a5b7c70d3aa10..fc93a17196e4e69405297331dbcd9e38943f5673 100644 (file)
@@ -452,6 +452,10 @@ define Image/Build/Profile/DIR600A1
        $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,dir-600-a1,board=DIR-600-A1,"AP91-AR7240-RT-090223-00")
 endef
 
+define Image/Build/Profile/EAP7660D
+       $(call Image/Build/Template/$(fs_128k)/$(1),PB4X,eap7660d,board=EAP7660D)
+endef
+
 define Image/Build/Profile/FR54RTR
        $(call Image/Build/Template/$(fs_64k)/$(1),Cameo7240,fr-54rtr,board=DIR-600-A1,"AP91-AR7240-RT-090223-01")
 endef
@@ -572,6 +576,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/DIR600A1,$(1))
        $(call Image/Build/Profile/DIR615C1,$(1))
        $(call Image/Build/Profile/DIR825B1,$(1))
+       $(call Image/Build/Profile/EAP7660D,$(1))
        $(call Image/Build/Profile/FR54RTR,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/MZKW300NH,$(1))
@@ -601,6 +606,7 @@ define Image/Build/Profile/Minimal
 endef
 
 define Image/Build/Profile/Madwifi
+       $(call Image/Build/Profile/EAP7660D,$(1))
        $(call Image/Build/Profile/UBNTRS,$(1))
        $(call Image/Build/Profile/UBNTRSPRO,$(1))
        $(call Image/Build/Profile/UBNTLSSR71,$(1))