create firmware image for the RouterStation Pro, and add a profile for it (patch...
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index fabe8de0b095094559a7abd011e1851415ea7e71..9f2a0458a56372489ebebf0b6606de910bab0aeb 100644 (file)
@@ -36,6 +36,27 @@ define Image/BuildKernel
                -d $(KDIR)/vmlinux.bin.lzma $(IMGNAME)-uImage-lzma.bin
 endef
 
+define Image/Build/Linksys8M
+       cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
+       $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
+       $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+       if [ `stat -c%s "$(KDIR)/vmlinux-$(2).bin.lzma"` -gt 1310720 ]; then \
+               echo "Warning: $(KDIR)/vmlinux-$(2).bin.lzma is too big"; \
+       else if [ `stat -c%s $(KDIR)/root.$(1)` -gt 6488064 ]; then \
+               echo "Warning: $(KDIR)/root.$(1) is too big"; \
+       else \
+               mkimage -A mips -O linux -T kernel -a 0x80060000 -C lzma -e \
+                       0x80060000 \
+                       -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+                       -d $(KDIR)/vmlinux-$(2).bin.lzma $(KDIR)/vmlinux-$(2).uImage; \
+               ( \
+                       dd if=$(KDIR)/vmlinux-$(2).uImage bs=1280k conv=sync; \
+                       dd if=$(KDIR)/root.$(1) bs=6336k conv=sync; \
+                       echo -n $(4); \
+               ) > $(call imgname,$(1),$(2)).bin; \
+       fi; fi
+endef
+
 define Image/Build/AP81
        cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
@@ -70,10 +91,10 @@ define Image/Build/UBNT
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
        dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
        -$(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(4) -v $(5).ar7100.OpenWrt.$(REVISION) \
+               -B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
                -k $(KDIR)/vmlinux-$(2).bin.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt-$(2)-$(1).bin
+               -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
 endef
 
 define Image/Build/Planex
@@ -118,6 +139,14 @@ define Image/Build/Template/Compex/squashfs
        $(call Image/Build/Template/Compex,squashfs,$(1))
 endef
 
+define Image/Build/Template/Linksys8M
+       $(call Image/Build/Linksys8M,$(1),$(2),$(3),$(4))
+endef
+
+define Image/Build/Template/Linksys8M/squashfs
+       $(call Image/Build/Template/Linksys8M,squashfs,$(1),$(2),$(3))
+endef
+
 define Image/Build/Template/AP81
        $(call Image/Build/AP81,$(1),$(2),$(3),$(4))
 endef
@@ -135,11 +164,11 @@ define Image/Build/Template/TPLINK/squashfs
 endef
 
 define Image/Build/Template/UBNT
-       $(call Image/Build/UBNT,$(1),$(2),$(3),$(4),$(5))
+       $(call Image/Build/UBNT,$(1),$(2),$(3),$(4),$(5),$(6))
 endef
 
 define Image/Build/Template/UBNT/squashfs
-       $(call Image/Build/Template/UBNT,squashfs,$(1),$(2),$(3),$(4))
+       $(call Image/Build/Template/UBNT,squashfs,$(1),$(2),$(3),$(4),$(5))
 endef
 
 define Image/Build/Template/Planex
@@ -171,30 +200,54 @@ define Image/Build/Profile/A02RBW300N
 endef
 
 define Image/Build/Profile/UBNTRS
-       $(call Image/Build/Template/UBNT/$(1),rs,board=UBNT-RS,RS,RSx)
+       $(call Image/Build/Template/UBNT/$(1),ubnt-rs,board=UBNT-RS,RS,RSx,ar7100)
+endef
+
+define Image/Build/Profile/UBNTRSPRO
+       $(call Image/Build/Template/UBNT/$(1),ubnt-rspro,board=UBNT-RSPRO,RSPRO,RSPRO,ar7100pro)
+endef
+
+define Image/Build/Profile/UBNTLSSR71
+       $(call Image/Build/Template/UBNT/$(1),ubnt-ls-sr71,board=UBNT-LS-SR71,LS-SR71,LS-SR71,ar7100)
+endef
+
+define Image/Build/Profile/UBNT
+       $(call Image/Build/Profile/UBNTRS,$(1))
+       $(call Image/Build/Profile/UBNTRSPRO,$(1))
+       $(call Image/Build/Profile/UBNTLSSR71,$(1))
 endef
 
 define Image/Build/Profile/MZKW04NU
        $(call Image/Build/Template/Planex/$(1),mzk-w04nu,board=MZK-W04NU)
 endef
 
+define Image/Build/Profile/TLWR841NDV3
+       $(call Image/Build/Template/TPLINK/$(1),tl-wr841ndv3,board=TL-WR941ND,TL-WR841NDv3)
+endef
+
 define Image/Build/Profile/TLWR941NDV2
        $(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
 endef
 
+define Image/Build/Profile/WRT400N
+       $(call Image/Build/Template/Linksys8M/$(1),wrt400n,board=WRT400N)
+endef
+
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/A02RBW300N,$(1))
        $(call Image/Build/Profile/DIR615C1,$(1))
        $(call Image/Build/Profile/MZKW04NU,$(1))
        $(call Image/Build/Profile/TEW632BRP,$(1))
        $(call Image/Build/Profile/TEW652BRP,$(1))
+       $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV2,$(1))
-       $(call Image/Build/Profile/UBNTRS,$(1))
+       $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
+       $(call Image/Build/Profile/WRT400N,$(1))
 endef
 
 define Image/Build/Profile/Madwifi
-       $(call Image/Build/Profile/UBNTRS,$(1))
+       $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
 endef