ar71xx: add profile and build image for the TP-Link TL-WR842N/ND v1 boards
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index f923efc37085a36c41fe0c6438e47ff6b2c20547..86e279f0a7de1c2c95b09987ce898347d6cbfbd5 100644 (file)
@@ -892,6 +892,11 @@ define Image/Build/Profile/TLWR841
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr841nd-v7,$(tlwr841v7_cmdline),0x08410007,1,4M)
 endef
 
+tlwr842_cmdline=board=TL-MR3420 console=ttyS0,115200
+define Image/Build/Profile/TLWR842
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK,tl-wr842n-v1,$(tlwr842_cmdline),0x08420001,1,8M)
+endef
+
 tlwr941v2_cmdline=board=TL-WR941ND console=ttyS0,115200
 tlwr941v4_cmdline=board=TL-WR741ND console=ttyS0,115200
 define Image/Build/Profile/TLWR941
@@ -1034,6 +1039,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR741,$(1))
        $(call Image/Build/Profile/TLWR743,$(1))
        $(call Image/Build/Profile/TLWR841,$(1))
+       $(call Image/Build/Profile/TLWR842,$(1))
        $(call Image/Build/Profile/TLWR941,$(1))
        $(call Image/Build/Profile/TLWR1043,$(1))
        $(call Image/Build/Profile/TLWR2543,$(1))