ar71xx: add ALL0305 board alias
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 43bb9d320c3959fcf008bdbabd0559a24e0f9a61..18f78897df4877c965eb9e6e1a5bc47d315a26f1 100644 (file)
@@ -661,6 +661,11 @@ define Image/Build/Profile/ALL0258N
        $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),$(all0258n_mtdlayout),1048576,5373952,KRuImage)
 endef
 
+all0305_cmdline=board=ALL0305 console=ttyS0,115200
+define Image/Build/Profile/ALL0305
+       $(call Image/Build/Template/$(fs_128k)/$(1),PB4X,all0305,$(all0305_cmdline))
+endef
+
 ap113_mtd_layout=64k(u-boot),3008k(rootfs),896k(uImage),64k(NVRAM),64k(ART),3904k@0x10000(firmware)
 ap113_cmdline=board=AP113 console=ttyS0,115200
 define Image/Build/Profile/AP113
@@ -1083,6 +1088,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ALFAAP96,$(1))
        $(call Image/Build/Profile/ALFANX,$(1))
        $(call Image/Build/Profile/ALL0258N,$(1))
+       $(call Image/Build/Profile/ALL0305,$(1))
        $(call Image/Build/Profile/AP113,$(1))
        $(call Image/Build/Profile/AP121,$(1))
        $(call Image/Build/Profile/AP121MINI,$(1))