ar71xx: add support for the TP-LINK TL-WR1043ND v3
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 29e5064909e6282b28eaf4c5b518e8c01fe5634b..09e5394fd93a90c55515888e512c3de88e1dac1e 100644 (file)
@@ -804,7 +804,14 @@ define Device/tl-wr1043nd-v2
     DEVICE_PROFILE := TLWR1043
     TPLINK_HWID := 0x10430002
 endef
-TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2
+
+define Device/tl-wr1043nd-v3
+    $(Device/tplink-8mlzma)
+    BOARDNAME := TL-WR1043ND-v2
+    DEVICE_PROFILE := TLWR1043
+    TPLINK_HWID := 0x10430003
+endef
+TARGET_DEVICES += tl-wr1043nd-v1 tl-wr1043nd-v2 tl-wr1043nd-v3
 
 define Device/tl-wr2543-v1
     $(Device/tplink-8mlzma)