ar71xx: create profile and build image for the TL-WDR4300 board
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 0a7d75a3dfa2d0c3cc2513f9e273391bfa5db046..06e39561d74791868a81a86a0971d14074f203ac 100644 (file)
@@ -974,6 +974,11 @@ define Image/Build/Profile/TLWR2543
        $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wr2543n-v1,$(tlwr2543_cmdline),0x25430001,1,8Mlzma)
 endef
 
+tlwdr4300_cmdline=board=TL-WDR4300 console=ttyS0,115200
+define Image/Build/Profile/TLWDR4300
+       $(call Image/Build/Template/$(fs_64kraw)/$(1),TPLINK-LZMA,tl-wdr4300-v1,$(tlwdr4300_cmdline),0x43000001,1,8Mlzma)
+endef
+
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),14848k(rootfs),64k(art)ro,15872k@0x70000(firmware)
@@ -1098,6 +1103,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLMR3420,$(1))
        $(call Image/Build/Profile/TLWA701,$(1))
        $(call Image/Build/Profile/TLWA901,$(1))
+       $(call Image/Build/Profile/TLWDR4300,$(1))
        $(call Image/Build/Profile/TLWR703,$(1))
        $(call Image/Build/Profile/TLWR740,$(1))
        $(call Image/Build/Profile/TLWR741,$(1))