ar71xx: add proper support for Archer-C7 V2
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index dba26672ab47e614504618df944de9659f2e113c..049abf311eac58358ab10d6621bf2fa58ada09e1 100644 (file)
@@ -411,7 +411,7 @@ endef
 
 define Device/archer-c7-v2
     $(Device/tplink-16mlzma)
-    BOARDNAME := ARCHER-C7
+    BOARDNAME := ARCHER-C7-V2
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
     IMAGE/factory.bin := append-rootfs | mktplinkfw factory -C US
@@ -1241,12 +1241,18 @@ define Device/ubnt-unifiac-lite
   BOARDNAME := UBNT-UF-AC-LITE
 endef
 
+define Device/ubnt-unifiac-pro
+  $(Device/ubnt-unifiac)
+  DEVICE_PROFILE := UBNT UBNTUNIFIACPRO
+  BOARDNAME := UBNT-UF-AC-PRO
+endef
+
 define Device/ubnt-unifi-outdoor
   $(Device/ubnt-bz)
   BOARDNAME := UBNT-U20
   DEVICE_PROFILE := UBNT UBNTUNIFIOUTDOOR
 endef
-TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifi-outdoor
+TARGET_DEVICES += ubnt-unifi ubnt-unifiac-lite ubnt-unifiac-pro ubnt-unifi-outdoor
 
 define Device/ubnt-nano-m-xw
   $(Device/ubnt-xw)