ar71xx: Support for Ubiquiti UniFi AP AC LITE
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / ubnt.mk
index 668171b8e6b5a61dfa76922f67583add221879bf..94eff18318264de85ea459e94280c88726404888 100644 (file)
@@ -38,6 +38,40 @@ endef
 
 $(eval $(call Profile,UBNTUNIFI))
 
+define Profile/UBNTUNIFIAC
+       NAME:=Ubiquiti UniFi AP AC
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x
+endef
+
+define Profile/UBNTUNIFIAC/Description
+       Package set optimized for the Ubiquiti UniFi AP AC.
+endef
+
+$(eval $(call Profile,UBNTUNIFIAC))
+
+define Profile/UBNTUNIFIOUTDOOR
+       NAME:=Ubiquiti UniFiAP Outdoor
+       PACKAGES:=
+endef
+
+define Profile/UBNTUNIFIOUTDOOR/Description
+       Package set optimized for the Ubiquiti UniFiAP Outdoor.
+endef
+
+$(eval $(call Profile,UBNTUNIFIOUTDOOR))
+
+define Profile/UAPPRO
+       NAME:=Ubiquiti UniFi AP Pro
+       PACKAGES:=
+endef
+
+define Profile/UAPPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP Pro.
+endef
+
+$(eval $(call Profile,UAPPRO))
+
+
 define Profile/UBNT
        NAME:=Ubiquiti Products
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2