ar71xx: Add support for Ubiquiti UniFi AP AC PRO
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / ubnt.mk
index eac02406bbbffebbcb20962929fb8254edba520e..69b83985bd6623c0d6732399d3e2cc8c0af9f9f1 100644 (file)
@@ -49,6 +49,17 @@ endef
 
 $(eval $(call Profile,UBNTUNIFIACLITE))
 
+define Profile/UBNTUNIFIACPRO
+       NAME:=Ubiquiti UniFi AP AC PRO
+       PACKAGES:=kmod-ath10k ath10k-firmware-qca988x kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+
+define Profile/UBNTUNIFIACPRO/Description
+       Package set optimized for the Ubiquiti UniFi AP AC PRO.
+endef
+
+$(eval $(call Profile,UBNTUNIFIACPRO))
+
 define Profile/UBNTUNIFIOUTDOOR
        NAME:=Ubiquiti UniFiAP Outdoor
        PACKAGES:=