ar71xx: add support for TP-LINK TL-WR843ND v1
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index d6516fed84e7add990b90946a03109af8367164f..c7a65e4af2e02b2643935a5eb45b627e1e406082 100644 (file)
@@ -6,16 +6,27 @@
 #
 
 define Profile/ARCHERC7
-       NAME:=TP-LINK Archer C7
+       NAME:=TP-LINK Archer C5/C7
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev kmod-ath10k
 endef
 
 define Profile/ARCHERC7/Description
-       Package set optimized for the TP-LINK Archer C7.
+       Package set optimized for the TP-LINK Archer C5/C7.
 endef
 $(eval $(call Profile,ARCHERC7))
 
 
+define Profile/CPE510
+       NAME:=TP-LINK CPE210/220/510/520
+       PACKAGES:=rssileds
+endef
+
+define Profile/CPE510/Description
+       Package set optimized for the TP-LINK CPE210/220/510/520.
+endef
+$(eval $(call Profile,CPE510))
+
+
 define Profile/TLMR10U
        NAME:=TP-LINK TL-MR10U
        PACKAGES:=kmod-usb-core kmod-usb2
@@ -301,6 +312,17 @@ endef
 $(eval $(call Profile,TLWR842))
 
 
+define Profile/TLWR843
+       NAME:=TP-LINK TL-WR843N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWR843/Description
+       Package set optimized for the TP-LINK TL-WR843N/ND.
+endef
+$(eval $(call Profile,TLWR843))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=