ar71xx: add profile and build image for the TL-MR13U board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 4ac6ba963272c5b67ab9fb7da2d41f854ba6819a..b7d4ec01ad1fa62b5b7b0c689499128f5f832e0a 100644 (file)
@@ -5,6 +5,28 @@
 # See /LICENSE for more information.
 #
 
+define Profile/ARCHERC7
+       NAME:=TP-LINK Archer C7
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/ARCHERC7/Description
+       Package set optimized for the TP-LINK Archer C7.
+endef
+$(eval $(call Profile,ARCHERC7))
+
+
+define Profile/TLMR10U
+       NAME:=TP-LINK TL-MR10U
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+define Profile/TLMR10U/Description
+       Package set optimized for the TP-LINK TL-MR10U.
+endef
+$(eval $(call Profile,TLMR10U))
+
+
 define Profile/TLMR11U
        NAME:=TP-LINK TL-MR11U
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -16,6 +38,17 @@ endef
 $(eval $(call Profile,TLMR11U))
 
 
+define Profile/TLMR13U
+       NAME:=TP-LINK TL-MR13U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR13U/Description
+       Package set optimized for the TP-LINK TL-MR13U.
+endef
+$(eval $(call Profile,TLMR13U))
+
+
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
@@ -72,6 +105,18 @@ endef
 $(eval $(call Profile,TLWR703))
 
 
+define Profile/TLWR710
+       NAME:=TP-LINK TL-WR710N
+       PACKAGES:=kmod-usb-core kmod-usb2
+endef
+
+
+define Profile/TLWR710/Description
+       Package set optimized for the TP-LINK TL-WR710N.
+endef
+$(eval $(call Profile,TLWR710))
+
+
 define Profile/TLWR720
        NAME:=TP-LINK TL-WR720N
        PACKAGES:=kmod-usb-core kmod-usb2
@@ -137,12 +182,12 @@ $(eval $(call Profile,TLWA901))
 
 
 define Profile/TLWDR4300
-       NAME:=TP-LINK TL-WDR3500/3600/4300/4310
+       NAME:=TP-LINK TL-WDR3500/3600/4300/4310/MW4350R
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWDR4300/Description
-       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310.
+       Package set optimized for the TP-LINK TL-WDR3500/3600/4300/4310/MW4350R.
 endef
 $(eval $(call Profile,TLWDR4300))