ar71xx: add profile and build image for the TP-Link TL-WR842N/ND v1 boards
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 2b9aa0e2186852bc09c06121166d24cb21e9522e..96ff12ae74cd432c42c39376009580b4c36a2cd5 100644 (file)
@@ -5,9 +5,20 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR11U
+       NAME:=TP-LINK TL-MR11U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR11U/Description
+       Package set optimized for the TP-LINK TL-MR11U.
+endef
+$(eval $(call Profile,TLMR11U))
+
+
 define Profile/TLMR3020
        NAME:=TP-LINK TL-MR3020
-       PACKAGES:=kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLMR3020/Description
@@ -116,6 +127,17 @@ endef
 $(eval $(call Profile,TLWR841))
 
 
+define Profile/TLWR842
+       NAME:=TP-LINK TL-WR842N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR842/Description
+       Package set optimized for the TP-LINK TL-WR842N/ND.
+endef
+$(eval $(call Profile,TLWR842))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=
@@ -136,3 +158,14 @@ define Profile/TLWR1043/Description
        Package set optimized for the TP-LINK TL-WR1043N/ND.
 endef
 $(eval $(call Profile,TLWR1043))
+
+
+define Profile/TLWR2543
+       NAME:=TP-LINK TL-WR2543N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR2543/Description
+       Package set optimized for the TP-LINK TL-WR2543N/ND.
+endef
+$(eval $(call Profile,TLWR2543))