ar71xx: add profile and build image for TP-Link TL-WDR4900 v2.0 board
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index b7d4ec01ad1fa62b5b7b0c689499128f5f832e0a..93312740d6b47bfb7ad9e03738f1944f377a1f61 100644 (file)
@@ -139,6 +139,18 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+
+define Profile/TLWA750
+       NAME:=TP-LINK TL-WA750RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA750/Description
+       Package set optimized for the TP-LINK TL-WA750RE.
+endef
+$(eval $(call Profile,TLWA750))
+
+
 define Profile/TLWA7510
        NAME:=TP-LINK TL-WA7510N
        PACKAGES:=
@@ -170,6 +182,17 @@ endef
 $(eval $(call Profile,TLWA830))
 
 
+define Profile/TLWA850
+       NAME:=TP-LINK TL-WA850RE
+       PACKAGES:=rssileds
+endef
+
+define Profile/TLWA850/Description
+       Package set optimized for the TP-LINK TL-WA850RE.
+endef
+$(eval $(call Profile,TLWA850))
+
+
 define Profile/TLWA901
        NAME:=TP-LINK TL-WA901N/ND
        PACKAGES:=
@@ -192,6 +215,17 @@ endef
 $(eval $(call Profile,TLWDR4300))
 
 
+define Profile/TLWDR4900V2
+       NAME:=TP-LINK TL-WDR4900v2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWDR4900V2/Description
+       Package set optimized for the TP-LINK TL-WDR4900v2.
+endef
+$(eval $(call Profile,TLWDR4900V2))
+
+
 define Profile/TLWR740
        NAME:=TP-LINK TL-WR740N/ND
        PACKAGES:=