ar71xx: TL-WA7210n v2 support
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 78333be0b5a4ef5e2ec6b4887184e1da15f5c60b..0174a431b13d31d6b2f3b3a91b40ae90267fee3b 100644 (file)
@@ -16,6 +16,17 @@ endef
 $(eval $(call Profile,ARCHERC7))
 
 
+define Profile/CPE510
+       NAME:=TP-LINK CPE210/220/510/520
+       PACKAGES:=rssileds
+endef
+
+define Profile/CPE510/Description
+       Package set optimized for the TP-LINK CPE210/220/510/520.
+endef
+$(eval $(call Profile,CPE510))
+
+
 define Profile/TLMR10U
        NAME:=TP-LINK TL-MR10U
        PACKAGES:=kmod-usb-core kmod-usb2
@@ -37,6 +48,16 @@ define Profile/TLMR11U/Description
 endef
 $(eval $(call Profile,TLMR11U))
 
+define Profile/TLMR12U
+       NAME:=TP-LINK TL-MR12U
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR12U/Description
+       Package set optimized for the TP-LINK TL-MR12U.
+endef
+
+$(eval $(call Profile,TLMR12U))
 
 define Profile/TLMR13U
        NAME:=TP-LINK TL-MR13U
@@ -139,6 +160,16 @@ define Profile/TLWA701/Description
 endef
 $(eval $(call Profile,TLWA701))
 
+define Profile/TLWA7210
+        NAME:=TP-LINK TL-WA7210N
+        PACKAGES:=rssileds kmod-ledtrig-netdev
+endef
+
+define Profile/TLWA7210/Description
+        Package set optimized for the TP-LINK TL-WA7210N.
+endef
+$(eval $(call Profile,TLWA7210))
+
 define Profile/TLWA730RE
        NAME:=TP-LINK TL-WA730RE
        PACKAGES:=
@@ -301,6 +332,17 @@ endef
 $(eval $(call Profile,TLWR842))
 
 
+define Profile/TLWR843
+       NAME:=TP-LINK TL-WR843N/ND
+       PACKAGES:=
+endef
+
+define Profile/TLWR843/Description
+       Package set optimized for the TP-LINK TL-WR843N/ND.
+endef
+$(eval $(call Profile,TLWR843))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=