ar71xx: convert OM2P to device profile
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / openmesh.mk
index 7c874112554f0ce997594a3e929a804cedce2b36..dbdf16959fed00ce1217bb9709c8b418dcb517d0 100644 (file)
@@ -5,16 +5,27 @@
 # See /LICENSE for more information.
 #
 
-define Profile/OM2P
-       NAME:=OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-LC
+define Profile/OM5P
+       NAME:=OpenMesh OM5P/OM5P-AN
        PACKAGES:=kmod-ath9k om-watchdog
 endef
 
-define Profile/OM2P/Description
-       Package set optimized for the OpenMesh OM2P/OM2Pv2/OM2P-HS/OM2P-LC.
+define Profile/OM5P/Description
+       Package set optimized for the OpenMesh OM5P/OM5P-AN.
 endef
 
-$(eval $(call Profile,OM2P))
+$(eval $(call Profile,OM5P))
+
+define Profile/OM5PAC
+       NAME:=OpenMesh OM5P-AC/OM5P-ACv2
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
+endef
+
+define Profile/OM5PAC/Description
+       Package set optimized for the OpenMesh OM5P-AC/OM5P-ACv2.
+endef
+
+$(eval $(call Profile,OM5PAC))
 
 define Profile/MR600
         NAME:=OpenMesh MR600
@@ -27,9 +38,31 @@ endef
 
 $(eval $(call Profile,MR600))
 
+define Profile/MR900
+        NAME:=OpenMesh MR900/MR900v2
+        PACKAGES:=kmod-ath9k om-watchdog
+endef
+
+define Profile/MR900/Description
+        Package set optimized for the OpenMesh MR900/MR900v2.
+endef
+
+$(eval $(call Profile,MR900))
+
+define Profile/MR1750
+        NAME:=OpenMesh MR1750/MR1750v2
+        PACKAGES:=kmod-ath9k kmod-ath10k
+endef
+
+define Profile/MR1750/Description
+        Package set optimized for the OpenMesh MR1750/MR1750v2.
+endef
+
+$(eval $(call Profile,MR1750))
+
 define Profile/OPENMESH
        NAME:=OpenMesh products
-       PACKAGES:=kmod-ath9k om-watchdog
+       PACKAGES:=kmod-ath9k kmod-ath10k om-watchdog
 endef
 
 define Profile/OPENMESH/Description