kernel: fix missing break in ubi auto-mounting patch
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index 597c7aa3dfc5827aad6d183419d0d476dea1227d..2bce72124445c39021ad39e82f044f2c23fff935 100644 (file)
@@ -30,6 +30,7 @@ $(eval $(call Profile,WNDR3700))
 
 define Profile/WNR2000V3
        NAME:=NETGEAR WNR2000V3
+       PACKAGES:= -kmod-usb-core -kmod-usb-ohci -kmod-usb2 -kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR2000V3/Description
@@ -39,19 +40,43 @@ endef
 $(eval $(call Profile,WNR2000V3))
 
 
+define Profile/WNR2000V4
+       NAME:=NETGEAR WNR2000V4
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNR2000V4/Description
+       Package set optimized for the NETGEAR WNR2000V4
+endef
+
+$(eval $(call Profile,WNR2000V4))
+
+
 define Profile/WNR612V2
-       NAME:=NETGEAR WNR612V2
+       NAME:=NETGEAR WNR612V2 / On Networks N150
 endef
 
 define Profile/WNR612V2/Description
-       Package set optimized for the NETGEAR WNR612V2
+       Package set optimized for the NETGEAR WNR612V2 / On Networks N150
 endef
 
 $(eval $(call Profile,WNR612V2))
 
 
+define Profile/WNR1000V2
+       NAME:=NETGEAR WNR1000V2
+endef
+
+define Profile/WNR1000V2/Description
+       Package set optimized for the NETGEAR WNR1000V2
+endef
+
+$(eval $(call Profile,WNR1000V2))
+
+
 define Profile/WNR2200
-       NAME:=NETGEAR WNR2200
+  NAME:=NETGEAR WNR2200
+  PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/WNR2200/Description
@@ -59,3 +84,13 @@ define Profile/WNR2200/Description
 endef
 
 $(eval $(call Profile,WNR2200))
+
+define Profile/WPN824N
+       NAME:=NETGEAR WPN824N
+endef
+
+define Profile/WPN824N/Description
+       Package set optimized for the NETGEAR WPN824N
+endef
+
+$(eval $(call Profile,WPN824N))