ar71xx: add Netgear WNR1000v2/WNR1000v2-VC support (#18633)
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index ff25f695a029f35662f9d68406773273173e747c..16b1087635df49e1c2cb61ec47675cdfa27de5b4 100644 (file)
@@ -1,10 +1,21 @@
 #
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
+define Profile/WNDAP360
+        NAME:=NETGEAR WNDAP360
+        PACKAGES:=
+endef
+
+define Profile/WNDAP360/Description
+        Package set optimized for the NETGEAR WNDAP360
+endef
+
+$(eval $(call Profile,WNDAP360))
+
 define Profile/WNDR3700
        NAME:=NETGEAR WNDR3700/WNDR3800/WNDRMAC
        PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev kmod-leds-wndr3700-usb
@@ -17,14 +28,57 @@ endef
 $(eval $(call Profile,WNDR3700))
 
 
-define Profile/WNDR4300
-       NAME:=NETGEAR WNDR4300
-       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+define Profile/WNR2000V3
+       NAME:=NETGEAR WNR2000V3
+endef
+
+define Profile/WNR2000V3/Description
+       Package set optimized for the NETGEAR WNR2000V3
+endef
+
+$(eval $(call Profile,WNR2000V3))
+
+
+define Profile/WNR2000V4
+       NAME:=NETGEAR WNR2000V4
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNR2000V4/Description
+       Package set optimized for the NETGEAR WNR2000V4
+endef
+
+$(eval $(call Profile,WNR2000V4))
+
+
+define Profile/WNR612V2
+       NAME:=NETGEAR WNR612V2 / On Networks N150
+endef
+
+define Profile/WNR612V2/Description
+       Package set optimized for the NETGEAR WNR612V2 / On Networks N150
+endef
+
+$(eval $(call Profile,WNR612V2))
+
+
+define Profile/WNR1000V2
+       NAME:=NETGEAR WNR1000V2
 endef
 
-define Profile/WNDR4300/Description
-       Package set optimized for the NETGEAR WNDR4300
+define Profile/WNR1000V2/Description
+       Package set optimized for the NETGEAR WNR1000V2
 endef
 
-$(eval $(call Profile,WNDR4300))
+$(eval $(call Profile,WNR1000V2))
+
+
+define Profile/WNR2200
+       NAME:=NETGEAR WNR2200
+endef
+
+define Profile/WNR2200/Description
+       Package set optimized for the NETGEAR WNR2200
+endef
 
+$(eval $(call Profile,WNR2200))