ar71xx: add preliminary support for wzr-hp-g450h
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / buffalo.mk
index 5358fb9195ce7c6b3d021b802a862a96a60d946e..e975eb8ad999767b56ab755b350e78db7819d7ad 100644 (file)
@@ -21,8 +21,54 @@ define Profile/WZRHPAG300H
        PACKAGES:=kmod-usb-ohci kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
-define Profile/WZRHPG30XNH/Description
+define Profile/WZRHPAG300H/Description
        Package set optimized for the Buffalo WZR-HP-AG300H
 endef
 
 $(eval $(call Profile,WZRHPAG300H))
+
+define Profile/WZRHPG450H
+       NAME:=Buffalo WZR-HP-G450H
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZRHPG450H/Description
+       Package set optimized for the Buffalo WZR-HP-G450H
+endef
+
+$(eval $(call Profile,WZRHPG450H))
+
+define Profile/WHRG301N
+       NAME:=Buffalo WHR-G301N
+       PACKAGES:=
+endef
+
+define Profile/WHRG301N/Description
+       Package set optimized for the Buffalo WHR-G301N.
+endef
+
+$(eval $(call Profile,WHRG301N))
+
+
+define Profile/WHRHPG300N
+       NAME:=Buffalo WHR-HP-G300N
+       PACKAGES:=
+endef
+
+define Profile/WHRHPG300N/Description
+       Package set optimized for the Buffalo WHR-HP-G300N
+endef
+
+$(eval $(call Profile,WHRHPG300N))
+
+
+define Profile/WHRHPGN
+       NAME:=Buffalo WHR-HP-GN
+       PACKAGES:=
+endef
+
+define Profile/WHRHPGN/Description
+       Package set optimized for the Buffalo WHR-HP-GN.
+endef
+
+$(eval $(call Profile,WHRHPGN))