ar71xx: add support for TP-Link TL-MR3020
[openwrt/openwrt.git] / target / linux / ar71xx / files / arch / mips / ar71xx / Makefile
index 9300d7a500458ac83297c65843e4c0e6c33d41c0..0cb277e828227347bb5c08ff99cc22f3283961e1 100644 (file)
@@ -28,6 +28,7 @@ obj-$(CONFIG_AR71XX_DEV_USB)          += dev-usb.o
 obj-$(CONFIG_AR71XX_NVRAM)             += nvram.o
 obj-$(CONFIG_AR71XX_PCI_ATH9K_FIXUP)   += pci-ath9k-fixup.o
 
+obj-$(CONFIG_AR71XX_MACH_ALFA_NX)      += mach-alfa-nx.o
 obj-$(CONFIG_AR71XX_MACH_ALL0258N)     += mach-all0258n.o
 obj-$(CONFIG_AR71XX_MACH_AP121)                += mach-ap121.o
 obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
@@ -52,6 +53,7 @@ obj-$(CONFIG_AR71XX_MACH_PB92)                += mach-pb92.o
 obj-$(CONFIG_AR71XX_MACH_RB4XX)                += mach-rb4xx.o
 obj-$(CONFIG_AR71XX_MACH_RB750)                += mach-rb750.o
 obj-$(CONFIG_AR71XX_MACH_TEW_632BRP)   += mach-tew-632brp.o
+obj-$(CONFIG_AR71XX_MACH_TL_MR3020)    += mach-tl-mr3020.o
 obj-$(CONFIG_AR71XX_MACH_TL_MR3X20)    += mach-tl-mr3x20.o
 obj-$(CONFIG_AR71XX_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
 obj-$(CONFIG_AR71XX_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o