px5g-standalone: provide px5g via PROVIDES
[openwrt/openwrt.git] / package / utils / px5g-standalone / Makefile
index fc5f391bf7d2de68f5a6536b276866583c517c41..b8f68d7bf38e0e78f8101dc5cbf8c4e756c8b977 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+# Copyright (C) 2010-2014 Jo-Philipp Wich <xm@subsignal.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,19 +7,20 @@
 
 include $(TOPDIR)/rules.mk
 
-PKG_NAME:=px5g
-PKG_RELEASE:=1
+PKG_NAME:=px5g-standalone
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
-PKG_CHECK_FORMAT_SECURITY:=0
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/px5g-standalone
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=Standalone X.509 certificate generator (standalone version)
+  SUBMENU:=Encryption
+  TITLE:=X.509 certificate generator (standalone version)
   MAINTAINER:=Jo-Philipp Wich <xm@subsignal.org>
+  PROVIDES:=px5g
 endef
 
 define Package/px5g-standalone/description
@@ -28,11 +29,6 @@ define Package/px5g-standalone/description
  and PEM format for use with stunnel, uhttpd and others.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
 define Package/px5g-standalone/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g