fstools: update to latest HEAD
[openwrt/openwrt.git] / package / system / fstools / Makefile
index ccaac6eb18a2a3c8488ebff3ce5245b51504096f..b70090842aeb9e5a372bd5749b282cfaaa341249 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_VERSION:=2015-11-22
+PKG_VERSION:=2016-07-24
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/fstools.git
+PKG_SOURCE_URL=$(LEDE_GIT)/project/fstools.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=86ebc116da42168a1b57204c98747c6cccebdc68
+PKG_SOURCE_VERSION:=addd7dc21fe99f2701c1d4708071578052af401d
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
@@ -24,7 +24,7 @@ PKG_LICENSE_FILES:=
 
 PKG_USE_MIPS16:=0
 
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_MAINTAINER:=John Crispin <john@phrozen.org>
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
@@ -50,6 +50,13 @@ define Package/fstools/config
                        This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
 endef
 
+define Package/snapshot-tool
+  SECTION:=base
+  CATEGORY:=Base system
+  TITLE:=rootfs snapshoting tool
+  DEPENDS:=+libubox +fstools
+endef
+
 define Package/block-mount
   SECTION:=base
   CATEGORY:=Base system
@@ -60,12 +67,18 @@ endef
 define Package/fstools/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib
 
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset,snapshot_tool} $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,jffs2reset} $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libfstools.so $(1)/lib/
-       $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
        $(LN) jffs2reset $(1)/sbin/jffs2mark
 endef
 
+define Package/snapshot-tool/install
+       $(INSTALL_DIR) $(1)/sbin
+
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/snapshot_tool $(1)/sbin/
+       $(INSTALL_BIN) ./files/snapshot $(1)/sbin/
+endef
+
 define Package/block-mount/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
@@ -88,4 +101,5 @@ define Build/InstallDev
 endef
 
 $(eval $(call BuildPackage,fstools))
+$(eval $(call BuildPackage,snapshot-tool))
 $(eval $(call BuildPackage,block-mount))