map: delete map-t device when tearing down map interface
[openwrt/openwrt.git] / package / network / ipv6 / map / Makefile
index 3757ed608820c75ca853d6d59d77a4171c13a2d6..9e51c40531ee2c96c0eaf4b6de4ab4dcc26b1c5b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=4
-PKG_RELEASE:=2
+PKG_RELEASE:=6
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
@@ -18,7 +18,7 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/map
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+kmod-ipv6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
+  DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
   TITLE:=MAP-E and Lightweight 4over6 configuration support
   MAINTAINER:=Steven Barth <steven@midlink.org>
 endef
@@ -30,11 +30,6 @@ define Package/map/description
  configuration details.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       $(CP) ./src/* $(PKG_BUILD_DIR)/
-endef
-
 define Package/map/install
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) ./files/map.sh $(1)/lib/netifd/proto/map.sh