elfutils: bump to 0.169
[openwrt/openwrt.git] / package / libs / elfutils / patches / 101-no-fts.patch
index b1b23089fddc47bead76a74e47ac31cff96b46f4..63699fea26fb33e3af2ca376217ece985e4e8acd 100644 (file)
@@ -1,6 +1,8 @@
---- a/libdwfl/argp-std.c
-+++ b/libdwfl/argp-std.c
-@@ -52,9 +52,6 @@ static const struct argp_option options[
+Index: elfutils-0.169/libdwfl/argp-std.c
+===================================================================
+--- elfutils-0.169.orig/libdwfl/argp-std.c
++++ elfutils-0.169/libdwfl/argp-std.c
+@@ -56,9 +56,6 @@ static const struct argp_option options[
    { "linux-process-map", 'M', "FILE", 0,
      N_("Find addresses in files mapped as read from FILE"
         " in Linux /proc/PID/maps format"), 0 },
@@ -10,7 +12,7 @@
    { "debuginfo-path", OPT_DEBUGINFO, "PATH", 0,
      N_("Search path for separate debuginfo files"), 0 },
    { NULL, 0, NULL, 0, NULL, 0 }
-@@ -81,15 +78,6 @@ static const Dwfl_Callbacks proc_callbac
+@@ -85,15 +82,6 @@ static const Dwfl_Callbacks proc_callbac
      .find_elf = INTUSE(dwfl_linux_proc_find_elf),
    };
  
@@ -26,7 +28,7 @@
  /* Structure held at state->HOOK.  */
  struct parse_opt
  {
-@@ -219,43 +207,6 @@ parse_opt (int key, char *arg, struct ar
+@@ -223,43 +211,6 @@ parse_opt (int key, char *arg, struct ar
        }
        break;
  
      case ARGP_KEY_SUCCESS:
        {
        struct parse_opt *opt = state->hook;
---- a/libdwfl/Makefile.in
-+++ b/libdwfl/Makefile.in
-@@ -121,7 +121,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
+Index: elfutils-0.169/libdwfl/Makefile.in
+===================================================================
+--- elfutils-0.169.orig/libdwfl/Makefile.in
++++ elfutils-0.169/libdwfl/Makefile.in
+@@ -120,7 +120,7 @@ am__libdwfl_a_SOURCES_DIST = dwfl_begin.
        dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
        dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
        find-debuginfo.c dwfl_build_id_find_elf.c \
@@ -81,7 +85,7 @@
        linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
        dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
        dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -150,7 +150,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
+@@ -148,7 +148,7 @@ am_libdwfl_a_OBJECTS = dwfl_begin.$(OBJE
        dwfl_validate_address.$(OBJEXT) argp-std.$(OBJEXT) \
        find-debuginfo.$(OBJEXT) dwfl_build_id_find_elf.$(OBJEXT) \
        dwfl_build_id_find_debuginfo.$(OBJEXT) \
@@ -90,7 +94,7 @@
        dwfl_addrmodule.$(OBJEXT) dwfl_addrdwarf.$(OBJEXT) \
        cu.$(OBJEXT) dwfl_module_nextcu.$(OBJEXT) \
        dwfl_nextcu.$(OBJEXT) dwfl_cumodule.$(OBJEXT) \
-@@ -425,7 +425,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
+@@ -434,7 +434,7 @@ libdwfl_a_SOURCES = dwfl_begin.c dwfl_en
        dwfl_getmodules.c dwfl_getdwarf.c dwfl_module_getdwarf.c \
        dwfl_module_getelf.c dwfl_validate_address.c argp-std.c \
        find-debuginfo.c dwfl_build_id_find_elf.c \
        linux-proc-maps.c dwfl_addrmodule.c dwfl_addrdwarf.c cu.c \
        dwfl_module_nextcu.c dwfl_nextcu.c dwfl_cumodule.c \
        dwfl_module_addrdie.c dwfl_addrdie.c lines.c dwfl_lineinfo.c \
-@@ -562,7 +562,6 @@ distclean-compile:
+@@ -571,7 +571,6 @@ distclean-compile:
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/lines.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/link_map.Po@am__quote@
  @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/linux-core-attach.Po@am__quote@