kernel/modules: add SSSE3 SHA512 module
[openwrt/openwrt.git] / package / kernel / linux / modules / crypto.mk
index 6e3f2cc1d2048bf7857bcc89be51223d5de0e821..c4f55e5c6f0d035b8b14d25303ea5b802fa6941d 100644 (file)
@@ -583,7 +583,8 @@ define KernelPackage/crypto-sha512
   DEPENDS:=+kmod-crypto-hash
   KCONFIG:= \
        CONFIG_CRYPTO_SHA512 \
-       CONFIG_CRYPTO_SHA512_OCTEON
+       CONFIG_CRYPTO_SHA512_OCTEON \
+       CONFIG_CRYPTO_SHA512_SSSE3
   FILES:=$(LINUX_DIR)/crypto/sha512_generic.ko
   AUTOLOAD:=$(call AutoLoad,09,sha512_generic)
   $(call AddDepends/crypto)
@@ -594,6 +595,11 @@ define KernelPackage/crypto-sha512/octeon
   AUTOLOAD:=$(call AutoLoad,09,octeon-sha512)
 endef
 
+define KernelPackage/crypto-sha512/x86/64
+  FILES+=$(LINUX_DIR)/arch/x86/crypto/sha512-ssse3.ko
+  AUTOLOAD:=$(call AutoLoad,09,sha512-ssse3)
+endef
+
 $(eval $(call KernelPackage,crypto-sha512))