layerscape: add 64b/32b target for ls1046ardb device
[openwrt/openwrt.git] / package / firmware / rcw / Makefile
index a412fd9f74da25bd3e8eb8a62cead0b712638993..8dfbfe95461a89a8e6e9e910900f5102f2816edb 100644 (file)
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=https://github.com/fsl-jyt/rcw.git
-PKG_SOURCE_VERSION:=e101d1207f402c7b761990a3e6681fdae8f253e3
+PKG_SOURCE_VERSION:=17e09e19bd5cf94e5ebc84916b4607743c29723e
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -35,6 +35,11 @@ define rcw/ls1043ardb
        CONFIG=ls1043ardb-rcw.bin
 endef
 
+define rcw/ls1046ardb
+       TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
+       CONFIG=ls1046ardb-rcw.bin
+endef
+
 define rcw/ls1012ardb
        TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 64b/32b Dev Board
        CONFIG=ls1012ardb-rcw.bin
@@ -42,6 +47,7 @@ endef
 
 RCWS := \
        ls1043ardb \
+       ls1046ardb \
        ls1012ardb
 
 define Package/rcw/template