sunxi: add support for Orange Pi Zero 3
[openwrt/openwrt.git] / package / boot / uboot-sunxi / Makefile
index de07dbdec2e97e2dc09a803794d215d2be881b80..112ea47d21d762f53a4a60372a4a081e3e072a1b 100644 (file)
@@ -339,6 +339,15 @@ define U-Boot/orangepi_zero2
   ATF:=h616
 endef
 
+define U-Boot/orangepi_zero3
+  BUILD_SUBTARGET:=cortexa53
+  NAME:=Xunlong Orange Pi Zero3
+  BUILD_DEVICES:=xunlong_orangepi-zero3
+  DEPENDS:=+PACKAGE_u-boot-orangepi_zero3:trusted-firmware-a-sunxi-h616
+  UENV:=h616
+  ATF:=h616
+endef
+
 define U-Boot/Bananapi_M2_Ultra
   BUILD_SUBTARGET:=cortexa7
   NAME:=Bananapi M2 Ultra
@@ -402,6 +411,7 @@ UBOOT_TARGETS := \
        orangepi_2 \
        orangepi_pc2 \
        orangepi_zero2 \
+       orangepi_zero3 \
        pangolin \
        pine64_plus \
        Sinovoip_BPI_M3 \