metadata.pl: add support for forcing sorting of profiles
[openwrt/openwrt.git] / include / target.mk
index 817901f0b9cdff8124931279c251b2ebd4363404..f4342bdbb532d40ece8e8892c789c466aaa3daa1 100644 (file)
@@ -59,6 +59,7 @@ extra_packages = $(if $(filter wpad-mini wpad nas,$(1)),iwinfo)
 
 define ProfileDefault
   NAME:=
+  PRIORITY:=
   PACKAGES:=
 endef
 
@@ -70,6 +71,7 @@ define Profile
   dumpinfo : $(call shexport,Profile/$(1)/Description)
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
+       $(if $(PRIORITY), echo "Target-Profile-Priority: $(PRIORITY)"; ) \
        echo "Target-Profile-Name: $(NAME)"; \
        echo "Target-Profile-Packages: $(PACKAGES) $(call extra_packages,$(DEFAULT_PACKAGES) $(PACKAGES))"; \
        if [ -f ./config/profile-$(1) ]; then \