ramips: add support for D-Link DAP-1620 B1
[openwrt/openwrt.git] / include / image-commands.mk
index 47d9d1ab8886b7a0669863531a17fac45a5b7ba7..0c13f30fef6c9587723b936016d7be929cbc2e63 100644 (file)
@@ -126,6 +126,13 @@ define Build/append-string
        echo -n $(1) >> $@
 endef
 
+define Build/append-md5sum-ascii-salted
+       cp $@ $@.salted
+       echo -ne $(1) >> $@.salted
+       $(STAGING_DIR_HOST)/bin/mkhash md5 $@.salted | head -c32 >> $@
+       rm $@.salted
+endef
+
 define Build/append-ubi
        sh $(TOPDIR)/scripts/ubinize-image.sh \
                $(if $(UBOOTENV_IN_UBI),--uboot-env) \