From: Hauke Mehrtens <hauke@hauke-m.de>
Date: Thu, 25 Feb 2016 22:31:51 +0000 (+0000)
Subject: kernel: deactivate the vdso gettimeofday function.
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=eea54160a1348acb338ec70b1700f6e7ee475e50;p=openwrt%2Fstaging%2Flynxis%2Fomap.git

kernel: deactivate the vdso gettimeofday function.

The vdso version of this function has some problems with the cache.
Very often it works on dated data which causes problem. We are
currently working on fixing this in upstream Linux kernel.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>

SVN-Revision: 48787
---

diff --git a/target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch b/target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch
new file mode 100644
index 0000000000..a77bdf84fe
--- /dev/null
+++ b/target/linux/generic/patches-4.4/340-MIPS-deactivate-gettimeofday-vdso.patch
@@ -0,0 +1,9 @@
+--- a/arch/mips/vdso/Makefile
++++ b/arch/mips/vdso/Makefile
+@@ -1,5 +1,5 @@
+ # Objects to go into the VDSO.
+-obj-vdso-y := elf.o gettimeofday.o sigreturn.o
++obj-vdso-y := elf.o sigreturn.o
+ 
+ # Common compiler flags between ABIs.
+ ccflags-vdso := \