From: Florian Fainelli <florian@openwrt.org>
Date: Mon, 5 May 2014 19:31:03 +0000 (+0000)
Subject: httping: fix build with NLS
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=de42fc4b0a4754c2f3b08f25190da5b1c343c025;p=openwrt%2Fsvn-archive%2Farchive.git

httping: fix build with NLS

v2: INTL support was not at default DEPENDS (broke nossl)

libintl.h was not found when CONFIG_BUILD_NLS was selected
explicit -lintl fixes
undefined reference to `libintl_gettext'

fixes ticket #15816

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Signed-off-by: Florian Fainelli <florian@openwrt.org>

SVN-Revision: 40701
---

diff --git a/net/httping/Makefile b/net/httping/Makefile
index 3c0b1ef35a..b0b41b17db 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -26,6 +26,7 @@ define Package/httping/Default
   CATEGORY:=Network
   TITLE:=Httping is like 'ping' but for http-requests
   URL:=http://www.vanheusden.com/httping/
+  DEPENDS:=$(INTL_DEPENDS)
 endef
 
 define Package/httping/Default/description
@@ -60,12 +61,14 @@ endef
 define Build/Configure
 endef
 
+TARGET_LDFLAGS += $(INTL_LDFLAGS) $(if $(INTL_FULL),-lintl)
+
 MAKE_FLAGS += \
 	DEBUG="no" \
 	FW="no" \
 	NC="no" \
 	TFO="no"
-	
+
 ifeq ($(BUILD_VARIANT),nossl)
 	MAKE_FLAGS += SSL="no"
 endif