From: Jo-Philipp Wich <jow@openwrt.org>
Date: Tue, 30 Apr 2013 10:16:31 +0000 (+0000)
Subject: miniupnpd: update v1.8.20130426 (#12997)
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=cb37fcbfc66224994438d8348a010b39cf4e1ec4;p=openwrt%2Fsvn-archive%2Fpackages.git

miniupnpd: update v1.8.20130426 (#12997)

	- pass network devices to miniupnpd
	- refresh patches

SVN-Revision: 36488
---

diff --git a/net/miniupnpd/Makefile b/net/miniupnpd/Makefile
index 0edd5d8a1..ec5a132a9 100644
--- a/net/miniupnpd/Makefile
+++ b/net/miniupnpd/Makefile
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=miniupnpd
-PKG_VERSION:=1.8
-PKG_RELEASE:=2
+PKG_VERSION:=1.8.20130426
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=http://miniupnp.free.fr/files
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=0d8a8e936d5a0012cb260a3b972acbf3
+PKG_MD5SUM:=ca5344eba200e4a6d1313849d68310f6
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/net/miniupnpd/files/miniupnpd.init b/net/miniupnpd/files/miniupnpd.init
index d747395ea..ef67d7246 100644
--- a/net/miniupnpd/files/miniupnpd.init
+++ b/net/miniupnpd/files/miniupnpd.init
@@ -106,9 +106,9 @@ start() {
 
 		local iface
 		for iface in ${intiface:-lan}; do
-			local ipnet
-			network_get_subnet ipnet "$iface" && {
-				echo "listening_ip=$ipnet" >>$tmpconf
+			local device
+			network_get_device device "$iface" && {
+				echo "listening_ip=$device" >>$tmpconf
 			}
 		done
 
diff --git a/net/miniupnpd/patches/100-gracefully-handle-missing-ipv6.patch b/net/miniupnpd/patches/100-gracefully-handle-missing-ipv6.patch
index 1e027d965..9378dedb4 100644
--- a/net/miniupnpd/patches/100-gracefully-handle-missing-ipv6.patch
+++ b/net/miniupnpd/patches/100-gracefully-handle-missing-ipv6.patch
@@ -67,7 +67,7 @@
  
  	if(bind(s, (struct sockaddr *)&listenname, listenname_len) < 0)
  	{
-@@ -1253,6 +1250,9 @@ main(int argc, char * * argv)
+@@ -1254,6 +1251,9 @@ main(int argc, char * * argv)
  	int sudp = -1;		/* IP v4 socket for receiving SSDP */
  #ifdef ENABLE_IPV6
  	int sudpv6 = -1;	/* IP v6 socket for receiving SSDP */
@@ -77,7 +77,7 @@
  #endif
  #ifdef ENABLE_NATPMP
  	int * snatpmp = NULL;
-@@ -1337,7 +1337,7 @@ main(int argc, char * * argv)
+@@ -1338,7 +1338,7 @@ main(int argc, char * * argv)
  	{
  
  		/* open socket for HTTP connections. Listen on the 1st LAN address */
@@ -97,8 +97,8 @@
  		i++;
  #endif
  	}
-@@ -406,6 +404,9 @@ SendSSDPNotifies(int s, const char * hos
- 	char bufr[512];
+@@ -495,6 +493,9 @@ SendSSDPNotifies(int s, const char * hos
+ 	int i=0;
  	char ver_str[4];
  
 +	if (s < 0)
@@ -107,7 +107,7 @@
  	memset(&sockname, 0, sizeof(sockname));
  #ifdef ENABLE_IPV6
  	if(ipv6)
-@@ -739,6 +740,10 @@ SendSSDPGoodbye(int * sockets, int n_soc
+@@ -868,6 +869,10 @@ SendSSDPGoodbye(int * sockets, int n_soc
  #ifdef ENABLE_IPV6
  		ipv6 = j & 1;
  #endif