From: Mirko Vogt <mirko-openwrt@nanl.de>
Date: Wed, 18 Jan 2017 13:36:45 +0000 (+0100)
Subject: git-kernel: $(SUBDIR) should always be $(LINUX_VERSION)
X-Git-Url: http://git.openwrt.org/?a=commitdiff_plain;h=c99f8815680fb4abf42cbb2e9d1a909f8f373b02;p=openwrt%2Fstaging%2Fsvanheule.git

git-kernel: $(SUBDIR) should always be $(LINUX_VERSION)

Before SUBDIR was set to $(PATCHVER) which may
or may not include the minor version number of
the linux kernel version. Usually it doesn't.

So the git-clone'd linux kernel was packed without
the minor version number taken into account, which
broke further processing, as it expected the
extracted dir being named linux-$(LINUX_VERSION)
(=with minor version) rather than linux-$(PATCHVER)
(=without minor version).

Changing SUBDIR to $(LINUX_VERSION) creates
consistent behaviour here.

Signed-off-by: Mirko Vogt <mirko-openwrt@nanl.de>
---

diff --git a/include/kernel-build.mk b/include/kernel-build.mk
index 2bf47b17e4..32da94babc 100644
--- a/include/kernel-build.mk
+++ b/include/kernel-build.mk
@@ -60,7 +60,7 @@ define Download/git-kernel
   PROTO:=git
   VERSION:=$(CONFIG_KERNEL_GIT_BRANCH)
   FILE:=$(LINUX_SOURCE)
-  SUBDIR:=linux-$(KERNEL_PATCHVER)
+  SUBDIR:=linux-$(LINUX_VERSION)
   OPTS:=$(KERNEL_GIT_OPTS)
 endef